A Fishkeeping forum. FishKeepingBanter.com

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » FishKeepingBanter.com forum » ponds » General
Site Map Home Authors List Search Today's Posts Mark Forums Read Web Partners

Beckett submersible died, anyone have a recommended replacement?



 
 
Thread Tools Display Modes
  #1  
Old May 20th 05, 02:09 AM
Mike Patterson
external usenet poster
 
Posts: n/a
Default Beckett submersible died, anyone have a recommended replacement?

1300 gal pond, pump ran pretty much continuously for about 2 years and
3 months. I guess that's not a bad MTBF rate.

A few days ago it started turning itself off every 3 minutes or so,
then after a couple minutes back on for another couple minutes.

Took it out of the pond, disassembled the lower case looking for clogs
or rubbing, nothing found. Internal metal motor casing getting hot
enough to burn my hand.

Don't know what would make a motor overheat by itself, guess it's time
to replace it.

So I'm looking for a replacement, any recommendations?

Or if someone knows how to fix it... brushes?


Mike
Mike Patterson
Please remove the spamtrap to email me.
"I always wanted to be somebody...I should have been more specific..." - Lily Tomlin

--
Posted via NewsDemon.com - Premium Uncensored Newsgroup Service
-------http://www.NewsDemon.com------
Unlimited Access, Anonymous Accounts, Uncensored Broadband Access
  #2  
Old May 20th 05, 03:20 AM
~ jan JJsPond.us
external usenet poster
 
Posts: n/a
Default

Pondmaster/Danner/Supreme Mag Drive pumps.

My first Beckett lasted 7 years, because it is after the filter and only
pumps clean water. ~ jan


1300 gal pond, pump ran pretty much continuously for about 2 years and
3 months. I guess that's not a bad MTBF rate.

A few days ago it started turning itself off every 3 minutes or so,
then after a couple minutes back on for another couple minutes.

Took it out of the pond, disassembled the lower case looking for clogs
or rubbing, nothing found. Internal metal motor casing getting hot
enough to burn my hand.

Don't know what would make a motor overheat by itself, guess it's time
to replace it.

So I'm looking for a replacement, any recommendations?

Or if someone knows how to fix it... brushes?


Mike
Mike Patterson
Please remove the spamtrap to email me.
"I always wanted to be somebody...I should have been more specific..." - Lily Tomlin


~Power to the Porg, Flow On!~
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie needs help with goldfish. All of them died in 2 days. :( [email protected] Goldfish 12 December 7th 04 07:17 PM
Newbie needs help with goldfish. All of them died in 2 days. :( [email protected]m General 8 December 7th 04 07:17 PM
EBO-Jager, Fully submersible or not? Tom B. Plants 6 April 16th 04 10:51 PM
Curious why algae died off in my tank Paul Vincent Craven General 3 February 6th 04 03:43 AM
Fully Submersible Heater JazzyB! General 4 December 12th 03 10:03 AM


All times are GMT +1. The time now is 02:40 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2004-2021 FishKeepingBanter.com.
The comments are property of their posters.